现象:

一. 手动方式安装svn插件

eclipse(已经装有svn插件)导入svn项目,项目没有svn的标记。

  1. 根据本地的svn客户端的版本,到 http://subclipse.tigris.org/ 下载eclipse对应版本的svn插件包

原因:

    注:装eclipse里面的svn插件,这步要根据我们本地的svn客户端的版本来找对应的eclipse中svn插件应该装的

1.可能是由于你的svn
eclipse插件,也就是subclipse,与svn的客户端版本不匹配。

    版本才能关联得上,否则关联会失败!

解决 :

    Eclipse SVN 插件与TortoiseSVN对应关系:

1.可以上subclipse的官网,找到与svn小乌龟客户端相匹配的
subclipse版本插件(《svn服务端和eclipse配合使用》这篇文章有安装方法)。然后把项目关闭再开启,即可。

      Subclipse 1.8.x  对应  Subversion 1.7.x client

 

     
Subclipse
1.10.x   对应  Subversion 1.8.x client

      Subclipse
1.12.x   对应  Subversion 1.9.x client

  2.
由于我的svn客户端版本是1.8.7,eclipse版本是3.7.0(indigo),则可下载site-1.10.13-1.9.x.zip;可点击此下载

  3.
在”eclipse安装路径\dropins\”目录下新建subclipse文件夹,将site-1.10.13-1.9.x.zip中的features和plugins

    解压缩到subclipse文件夹下。

  4.
重启eclipse,在Window—Preferences—Team下可看到SVN选项,表示插件安装成功。

 

二. 安装easyExplorer插件

  easyExplorer是一个Eclipse插件,主要用于快速浏览项目文件的目录,实用性比较强。

  1. 到http://sourceforge.net/projects/easystruts/ 下载org.sf.easyexplore_1.0.4.jar,或点击此下载

  2.
在”eclipse安装路径\dropins\”目录下新建”easyExplorer\plugins”文件夹,将org.sf.easyexplore_1.0.4.jar

    放到plugins文件夹下。

  3. 重启eclipse,右键某个文件或文件夹可看到”Easy
Explorer…”,表示插件安装成功

 

三. 安装Color Theme插件

  颜色主题插件,可选择自己的喜欢的eclipse配色方案,起到保护眼睛的作用

  1. 进入到eclipse中,打开Help—Eclipse
Marketplace…—在Search标签下,查找theme—找到Eclipse Color
Theme,点安装

  2.
重启eclipse,在Window—Preferences—General—Appearance下可看到Color
Theme选项,表示插件安装成功

相关文章